LandInvestors.com Forums +Resources for Success+ PacelFact -can’t find a parcel

Tagged: 

  • Creator
    Topic
  • #29823
    Chris Shude
    Participant
    Post count: 3

    I’m having some issues with finding parcels in PF. I’m looking for a parcel in a county where I’ve already looked up several, I am using the correct format, and I even confirmed the parcel number through the county website. What am I missing?

    I would try to find it through searching around the map by going to history and pulling up a parcel I’ve already looked at in the county and scanning from there, but now I’m only able to see the parcel that is looked up. There’s no other parcel boundaries or information coming up on the map. I cleared the cache and still no dice.

    Any ideas?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Author
    Replies
  • Kevin Farrell
    Moderator
    Post count: 2176

    Chris – Maybe you should log off and then log on. Then try rebooting the computer. The best way I can get PF to work for me is to only open it up in a private window in Firefox. That may just be my arrangement here.

    Kevin Farrell - Moderator
    Need more help?
    Schedule a 60 minute call - https://calendly.com/kevin-629

    Chris Shude
    Participant
    Post count: 3

    thanks for the suggestions, Kevin. I’ve tried all of them on two different laptops and I’m getting the same results. The issue is more extensive than I thought. I started entering in random parcels from my mailing list, including those that I’ve already looked up and that are in my history and was getting the message that the parcel couldn’t be found. I’m going to hang it up for the day on the assumption that there are updates taking place and will try again over the weekend. Appreciate the quick response and suggestions! Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.